Today's Deals (in Amazon.com)

 Question:

raspbian - Cannot unzip image files
  • florian

    I just downloaded raspbian from raspberrypi.org/downloads, and I cannot unzip the archive. (I am using ubuntu 12.04)

    Archive Manager says:

    7-Zip [64] 9.20  Copyright (c) 1999-2010 Igor Pavlov  2010-11-18
    p7zip Version 9.20 (locale=en_US.UTF-8,Utf16=on,HugeFiles=on,2 CPUs)
    
    Error: /home/homie/Downloads/NOOBS_v1_3.zip: Can not open file  as archive
    
    Errors: 1
    

    and unzip complains that

    Archive:  Downloads/2013-09-25-wheezy-raspbian.zip
    End-of-central-directory signature not found.  Either this file is not
    a zipfile, or it constitutes one disk of a multi-part archive.  In the
    latter case the central directory and zipfile comment will be found on
    the last disk(s) of this archive.
    unzip:  cannot find zipfile directory in one of Downloads/2013-09-25-wheezy-  raspbian.zip or
         Downloads/2013-09-25-wheezy-raspbian.zip.zip, and cannot find 
         Downloads/2013-09-25-wheezy-raspbian.zip.ZIP, period.
    

    I've tried the same with NOOBS_v1_3.zip, with the same result.

    Edit: I checked the shasums, and they don't match. So apparently the files are corrupted.

  •  Answers:

  • Arne

    In the download folder of Raspbian, you can find an SHA1 checksum for the zip-archive:

    99e6b5e6b8cfbf66e34437a74022fcf9744ccb1d  /var/www/raspbian/images/raspbian-2013-10-07/2013-09-25-wheezy-raspbian.zip
    

    Please run sha1sum 2013-09-25-wheezy-raspbian.zip and compare the output with the above checksum, or rather the checksum corresponding to your file. It will most probably not match. Then you should re-download. You can easily use wget to fetch Raspbian:

    wget http://downloads.raspberrypi.org/raspbian_latest